Tentative Appointments list not showing
Incident Report for Kalix EMR
Resolved
There does not seem to be any additional ongoing problems with these tentative appointment queries, so we will be resolving this issue.
Posted Sep 21, 2023 - 23:29 PDT
Monitoring
A second fix has been pushed up which should also filter out older appointments that were incorrectly showing up as tentative. We are currently monitoring for any additional problems.
Posted Sep 21, 2023 - 10:46 PDT
Investigating
It looks like our update to the query wasn't quite 100% as we do have reports of old tentative appointments showing up on some accounts. We are currently investigating this issue and hope to have a fix for this shortly. If your account is currently experiencing additional tentative appointments showing up, please contact us on [email protected]
Posted Sep 21, 2023 - 10:14 PDT
Monitoring
A fix has been pushed up to fix up the queries related to the tentative appointment search, and these seem to be coming up correctly. We will be monitoring Kalix to see if there are any related issues.
Posted Sep 21, 2023 - 09:56 PDT
Investigating
Pending tentative appointments are not showing up in the calendar, and it seems like this is due to a change to how the database handles a specific filter. This filter is only used for tentative appointments, so this should not be an issue for other areas in Kalix, and tentative appointments are still visible in the calendar. We are working on a fix/workaround now.
Posted Sep 21, 2023 - 08:58 PDT
This incident affected: Kalix Platform.