The issue has been confirmed by Microsoft and has been escalated to an engineer. We will be continuing to work with them to get the database issue resolved.
Posted Jun 27, 2026 - 10:14 PDT
Update
We have tried to scale up the database; however, this process is currently stuck. It seems that there is a platform issue, so we have escalated this with the highest priority.
Posted Jun 27, 2026 - 09:23 PDT
Investigating
We are currently investigating an issue where our database is resetting continuously, which is causing timeouts to occur on Kalix. Right now, the timeouts seem are happening in waves and a refresh should recover once the database is back. We are currently investigating why this issue is occurring, as we cannot see an obvious spike in usage that would overload the database.
Posted Jun 27, 2026 - 08:15 PDT
This incident affects: Kalix Platform and Online Schedulers.