Square Credit Card Processing Degraded Performance
Incident Report for Kalix EMR
Resolved
Square's engineering team implemented a fix approximately 2 hours ago, and just now (07:19 AM EST), report services are in recovery and regaining functionality. Square's status page continues to show degraded performance, but credit card processing via Square should be operational. https://www.issquareup.com/
Posted Sep 08, 2023 - 04:25 PDT
Monitoring
Square's engineering team implemented a fix and services are beginning to recover and regain functionality. https://au.issquareup.com/
Posted Sep 08, 2023 - 02:15 PDT
Identified
There is currently a disruption with one of the data centers used by Square credit card processing, which is affecting its services. To get more information about this issue, kindly refer to their status page at https://www.issquareup.com.

It is important to note that Square is not affiliated with Kalix, and therefore we do not have any control over resolving this problem.
Posted Sep 07, 2023 - 14:04 PDT
This incident affected: Credit Card Charging.