Time out error (unknown error) & appointment breakdown issue
Incident Report for Kalix EMR
Resolved
A fix has been applied to the database for the original query issue, so you should be able to do appointment type breakdowns and clinician breakdowns on the appointments reports page again.
Posted Apr 19, 2023 - 20:42 PDT
Update
Just updating the status of components to match our latest update.
Posted Apr 11, 2023 - 00:38 PDT
Monitoring
Our provider confirmed that a number of optimizations were disabled on our database which caused the issues that we saw today, however these have been restored.

The reason these optimizations where disabled in the first place was to fix an issue with the breakdown queries in the appointment reports page (when you do a breakdown by 'Appointment Types' or 'Clinicians'). So these will throw an unknown error until a permanent fix is in place (that doesn't involve disabling optimizations).

We will be monitoring the database in the meantime, and will close this issue once the permanent fix for the appointment breakdowns have been completed.
Posted Apr 11, 2023 - 00:38 PDT
Update
We have significantly increased the capacity of the database to alleviate this issue, which has seemed to help a small amount. We are hoping this will provide some temporary relief until the root cause can be determined.

We have identified that the issue started in the database about 2.5 hours ago, but we are still trying to find the root cause.
Posted Apr 10, 2023 - 12:45 PDT
Investigating
There is some slowness affecting Kalix relating to the database timing out. We are currently investigating the issue and have contacted our cloud storage provider. We will keep you updated on our progress on this.
Posted Apr 10, 2023 - 12:07 PDT
This incident affected: Kalix Platform, Telehealth, Online Schedulers, Messaging, and Notifications.