Document & Reminder timeouts
Incident Report for Kalix EMR
Resolved
Kalix seems to be functioning normally
Posted Apr 26, 2022 - 15:38 PDT
Update
All Indexing is complete and we are currently confirming performance across the platform.
Posted Apr 26, 2022 - 14:36 PDT
Monitoring
From our own testing, it seems the server is starting to become more responsive as the indexing is coming to a close. The only index left is to do with documents. Document templates seem to be loading snappily in our test account.
Posted Apr 26, 2022 - 08:28 PDT
Update
The appointments and reminders indexing have completed! Out of the two remaining indexes, bills are 80% complete and documents are 30% complete. We expect once the indexing steps are complete that the timeouts should stop.

We will update this status again once we have more progress.
Posted Apr 26, 2022 - 06:57 PDT
Update
There are 4 indexes that need to be completed - docs, appointments, bills and reminders. Both appointments and reminders are over 50% complete.

We will update this status when we have more progress.
Posted Apr 26, 2022 - 06:03 PDT
Identified
There is currently an issue loading documents (including templates) and reminders. Some of these queries may work, but there may also be timeouts. Certain queries are more affected than others, depending on how they are loaded, and it seems like templates and reminders are particularly affected.

The underlying cause is that an indexing maintenance job was unsuccessful and now the index for these records has to be rebuilt. Until these indexes are complete, the queries loading the data will be inefficient and may take too long to complete and will come up with a timeout error.

Unfortunately, it may take an hour or two for these indexing tasks to be completed. We will update this incident once we have more idea of the progress.
Posted Apr 26, 2022 - 05:31 PDT
This incident affected: Kalix Platform and Messaging.