Document indexing

Incident Report for Kalix EMR

Resolved

We have rolled back the search to a previous version, so it can use our previous index. We we wait until the new index is built before using the new search.
Posted Mar 23, 2025 - 05:58 PDT

Monitoring

Documents will not show up on the 'Documents' -> 'Saved Documents' page and against clients, and there will also be an error shown.

This is related to a database update (there was an update on how documents are ordered, which requires updated 'indexes'). The indexes are currently being built on top of the documents - they are currently 20% complete so it may take a little while longer. Once the indexes are complete, document searches will complete successfully.

All other features of Kalix are working normally.

We will update this incident with progress on the indexes and when the update is complete.
Posted Mar 23, 2025 - 04:17 PDT
This incident affected: Kalix Platform.